SOS :: Security Operation Space
22 мая, среда, 00:00
|
Hot News:

В OpenSSH устранили уязвимость грозящую удаленным исполнением кода

06 февраля 2023 г., понедельник, 19:45

Вышедший на прошлой неделе релиз OpenSSH 9.2 содержит патч для уязвимости double-free, привнесенной с изменением кода в июле прошлого года. Эксплойт маловероятен, однако пользователей призывают обновить продукт, так как опасную ошибку можно вызвать на сервере в дефолтной конфигурации (sshd).

Согласно бюллетеню Qualys, проблема CVE-2023-25136 проявляется при попытке подключения по SSH (при выполнении процесса preauth). Ошибка освобождения блока памяти options.kex_algorithms возникает дважды — при выполнении функций do_ssh2_kex() и do_authentication2().

Эксплуатация сложна в исполнении: современные средства распределения памяти обеспечивают защиту от double-free и ее надо как-то обойти. Более того, уязвимый процесс preauth выполняется с низкими привилегиями и обычно в песочнице.

Уязвимости подвержен только выпуск OpenSSH 9.1, более ранним версиям она не страшна. Затронутым пользователям настоятельно рекомендуют перейти на сборку 9.2.

В новом выпуске устранены еще две проблемы в безопасности:

  • возможность пропуска проверки при использовании опции PermitRemoteOpen;
  • возможность модификации файлов known_hosts в ответах DNS-сервера (эксплойт маловероятен).

Ваш голос учтён!
нравится
не нравится Рейтинг:
-1
Всего голосов: 1
Комментарии

Добавить комментарий к новости

Ваше имя: *
Сообщение: *
Нет комментариев
19:45
17:45
14:45
12:45
11:45
09:45
09:45
19:45
18:45
16:45
15:45
14:45
13:45
10:45
10:45
09:45
19:45
19:45


© 2013—2024 SOS :: Security Operation Space (Пространство Операций Безопасности)  // AMS  // Обратная связь  | 0.072
Использование любых материалов, размещённых на сайте, разрешается при условии ссылки на sos.net.ua.