SOS :: Security Operation Space
11 апреля, воскресенье, 00:00
|
Hot News:

VMware устранила критическую RCE-уязвимость в vCenter Server

24 февраля 2021 г., среда, 15:15

Компания VMware выпустила обновления для платформы vCenter Server, устранив две уязвимости. Одна из них признана критической, поскольку позволяет удаленно и без аутентификации выполнить произвольный код.

Решение vCenter Server предоставляет ИТ-админу интерфейс для централизованного управления серверами и виртуальными машинами, с возможностью расширения локальной среды до публичных облаков на базе VMware vSphere. Наличие RCE-уязвимости в такой платформе грозит захватом контроля над системой и несанкционированным доступом к информации о виртуальной инфраструктуре предприятия.

Брешь, зарегистрированную под идентификатором CVE-2021-21972, обнаружил эксперт Positive Technologies Михаил Ключников. Согласно описанию VMware, эксплуатация этой уязвимости возможна при наличии сетевого доступа к порту 443. В случае успеха автор атаки сможет выполнить любую команду в системе с неограниченными привилегиями.

Виновником появления критической дыры является клиентский плагин к движку vROps (vRealize Operations, решение для автоматизации операций), который по умолчанию установлен на всех серверах vCenter. Ввиду большой площади атаки, простоты эксплойта и серьезности последствий степень опасности проблемы была оценена в 9,8 балла по шкале CVSS.

«По нашему мнению, RCE-уязвимость в vCenter Server составляет не меньшую угрозу, чем печально известная CVE-2019-19781 в Citrix», — заявил Ключников, комментируя свою находку для The Hacker News.

Патчи выпущены для vCenter Server веток 7.0, 6.7 и 6.5. Пользователям рекомендуется незамедлительно установить сборку 7.0 U1c, 6.7 U3l или 6.5 U3n соответственно. При отсутствии такой возможности можно ограничить возможность эксплойта, следуя инструкциям, приведенным в KB82374.

Вторая уязвимость, закрытая в vCenter Server (CVE-2021-21973), не столь опасна. Это возможность подмены запросов на стороне сервера (SSRF), которая возникла из-за некорректной реализации проверки URL в клиентском плагине платформы.

Разработчики также исправили опасную ошибку переполнения буфера в гипервизоре VMware ESXi (CVE-2021-21974; 8,8 балла), грозящую выполнением вредоносного кода. Эксплойт в данном случае осуществляется подачей по сети особого запроса по протоколу SLP.

Ваш голос учтён!
нравится
не нравится Рейтинг:
0
Всего голосов: 0
Комментарии

Добавить комментарий к новости

Ваше имя: *
Сообщение: *
Нет комментариев
16:15
14:15
11:15
08:15
07:15
06:15
16:15
15:15
12:15
10:15
08:15
08:15
07:15
07:15
06:15
16:15
15:15
15:15


© 2013—2021 SOS :: Security Operation Space (Пространство Операций Безопасности)  // Обратная связь  | 0.398
Использование любых материалов, размещённых на сайте, разрешается при условии ссылки на sos.net.ua.