SOS :: Security Operation Space
29 ноября, воскресенье, 00:00
|
Hot News:

В Drupal выявили и пропатчили критическую RCE-уязвимость

20 ноября 2020 г., пятница, 10:15

Разработчики Drupal устранили уязвимость удаленного исполнения кода, объявившуюся в компонентах ядра CMS-системы. Степень опасности проблемы, зарегистрированной как CVE-2020-13671, оценена в 17 баллов из 25 возможных по шкале, рекомендованной NIST (американским Институтом стандартов и технологий).

Согласно описанию на сайте Drupal, новая RCE-уязвимость возникла из-за неадекватной санации имен файлов, загружаемых на сервер. В результате система может интерпретировать расширение файла как некорректное и ошибиться при определении MIME-типа, а при некоторых настройках — даже запустить файл на исполнение как PHP.

Используя уязвимость, злоумышленник при наличии доступа может загрузить на сервер вредоносный файл определенного формата и добиться его исполнения в обход существующих ограничений.

Патчи выпущены для поддерживаемых версий CMS-системы — Drupal 7 и 9, а также веток 8.8 и 8.9. Пользователям рекомендуется обновить продукт до сборки 7.74, 9.0.8, 8.8.11 или 8.9.9 соответственно.

Кроме установки патча, разработчики советуют проверить ранее загруженные файлы на наличие подозрительных расширений, в особенности двойных. По их мнению, в ходе аудита также стоит обратить внимание на такие расширения, как phar, php, pl, py, cgi, html, htm, phtml, js и asp.

Ваш голос учтён!
нравится
не нравится Рейтинг:
1
Всего голосов: 1
Комментарии

Добавить комментарий к новости

Ваше имя: *
Сообщение: *
Нет комментариев
14:15
12:15
10:15
07:15
15:15
13:15
10:15
10:15
06:15
15:15
12:15
08:15
06:15
17:15
16:15
15:15
14:15
13:15


© 2013—2020 SOS :: Security Operation Space (Пространство Операций Безопасности)  // Обратная связь  | 0.358
Использование любых материалов, размещённых на сайте, разрешается при условии ссылки на sos.net.ua.