SOS :: Security Operation Space
11 декабря, среда, 00:00
|
Hot News:

Критический баг в плагине WordPress Ad Inserter позволяет выполнить код

16 июля 2019 г., вторник, 08:15

Плагин для движка WordPress Ad Inserter установили более 200 тыс. сайтов. Исследователи предупреждают: плагин уязвим, аутентифицированный атакующий может удаленно выполнить PHP-код.

Ad Inserter позволяет владельцам сайтов управлять рекламой на своих ресурсах и размещать ее в оптимальных местах. Этот плагин поддерживает Google AdSense, Google Ad Manager, Amazon Native Shopping Ads, Media.net и ротацию баннеров.

Найденная в аддоне уязвимость существует из-за использования check_admin_referer() для авторизации. Изначально эта функция была призвана защитить сайты от CSRF-атак.

Брешь получила статус критической, она актуальна для всех сайтов на WordPress, где установлен Ad Inserter 2.4.21 или более старые версии плагина. Обновление плагина до версии 2.4.22 поможет устранить эту проблему.

По словам команды Wordfence, аутентифицированный атакующий может обойти проверку авторизации, которую реализует функция check_admin_referer(). В результате злоумышленник сможет получить доступ к режиму отладки, предусмотренному в Ad Inserter.

Ваш голос учтён!
нравится
не нравится Рейтинг:
0
Всего голосов: 0
Комментарии

Добавить комментарий к новости

Ваше имя: *
Сообщение: *
Нет комментариев
16:12
15:04
14:15
14:15
12:15
10:15
09:15
07:15
06:15
15:15
15:11
14:44
14:15
12:15
11:15
10:15
09:15
08:15


© 2013—2019 SOS :: Security Operation Space (Пространство Операций Безопасности)  // Обратная связь  | 0.413
Использование любых материалов, размещённых на сайте, разрешается при условии ссылки на sos.net.ua.